Summary

The protected added to the error log file appear to be ignored due to a bug in PHP's CGI binary. This effectively causes it not to function properly.

Likely impacted PHP versions:
- PHP 5.2
- PHP 5.3

Impacted Joomla! versions:
- CMS 1.5, 1.6, 1.7 and 2.5 Betas
- All Platform releases

Related Reading:

Joomla! Platform Pull Request:
https://github.com/joomla/joomla-platform/pull/721


JBS Mailing List discussion thread:
http://groups.google.com/group/joomlabugsquad/browse_thread/thread/61d2a0979c55b418/908f7fcaee6a723d

PHP Bug:
https://bugs.php.net/bug.php?id=60677
Opened On:
7 Jan 2012, 3:12 by Samuel Moffatt
Status:
Confirmed

Filed Under

  • Administrator
  • PHP 5.3
  • PHP 5.3.x