Summary

Joomla 2.5.6 tells me that it cannot proceed for the following reason:
"You need SQL Server 2008 R2 (10.50.1600.1) or higher to continue the installation. Your version is: 10.50.1600".

This is incorrect. I'm running MS SQL Server 2008 R2 Standard with Service Pack 1.
> SELECT @@VERSION

Microsoft SQL Server 2008 R2 (RTM) - 10.50.1600.1 (X64) Apr 2 2010 15:48:46 Copyright (c) Microsoft Corporation Standard Edition (64-bit) on Windows NT 6.1 <X64> (Build 7601: Service Pack 1) (Hypervisor)

Opened On:
4 Sep 2012, 21:42 by Louis Rodriguez
Closed On:
8 May 2013, 11:15
Status:
Closed

Filed Under

  • IIS 7.x
  • Installation
  • MS SQL Srv
  • No Platform Implications
  • Other New Browser
  • PHP 5.3.x

Responses

Posted on 14 Sep 2012, 13:02 by Elin Waring
Do you also have this issue in the Joomla 3 beta? (I'd like to know if it has been fixed since 2.5.6 is running version 11.4 of the platform rather than 12.2)
Posted on 13 Apr 2013, 3:23 by Valentin Despa
Louis, can you please confirm if you are still having this problem in 2.5.9 (or later)?
Posted on 8 May 2013, 11:15 by Brian Teeman
I am closing this as there has been no response from the original reporter
Posted on 11 Dec 2013, 8:37 by Oliver Kinne

The problem still seems to persist in Joomla 3.2.0 beta 2, as well as the 3.2.0 stable versions.

The same message from Joomla:

"You need SQL Server 2008 R2 (10.50.1600.1) or higher to continue the installation. Your version is: 10.50.1600"

And when you do SELECT @@VERSION you get - and this is run within PHP 5.4 on IIS7.5, so the same setup as the Joomla site:

"Microsoft SQL Server 2008 R2 (RTM) - 10.50.1600.1 (X64) Apr 2 2010 15:48:46 Copyright (c) Microsoft Corporation Standard Edition (64-bit) on Windows NT 6.1 (Build 7601: Service Pack 1) (Hypervisor)"

So I definitely got the latest version, but it still refuses to continue. So I have applied the "workaround" of telling Joomla to accept 10.50.1600 as the minimum version.