Summary


Creating a filter for dates after start are not working.
There are two reasons for this
1. the xml file for the form sets the select box to -1 0 1 but allow is "before exact after"
2. In the file admin/comp/com_fin/helpers/indexer/query.php the function processStaticTaxonomy sets the values to the wrong variables names:
// Set the dates if not already set.
$this->dates->def('d1', $params->get('d1'));
$this->dates->def('d2', $params->get('d2'));
$this->dates->def('w1', $params->get('w1'));
$this->dates->def('w2', $params->get('w2'));
should be
// Set the dates if not already set.
$this->dates->def('date1', $params->get('d1'));
$this->dates->def('date2', $params->get('d2'));
$this->dates->def('when1', $params->get('w1'));
$this->dates->def('when2', $params->get('w2'));
after changing these to problems everything works fine.
Opened On:
15 Jan 2013, 14:04 by Harald Leithner
Closed On:
11 Jun 2014, 18:52
Status:
Fixed in SVN/GitHub

Filed Under

  • Forms
  • No Platform Implications

Responses

Posted on 16 Jan 2013, 0:44 by Jean-Marie Simonet
@test
Confirmed
Although I am not sure it works, the code above now displays the dates chosen in the filter in frontend (tested on 3.0).
Posted on 1 Mar 2013, 7:29 by Harald Leithner
Added patch with pull Request

https://github.com/joomla/joomla-cms/pull/745

https://github.com/joomla/joomla-cms/pull/745.diff
Posted on 23 Mar 2013, 14:44 by Nick Savov
Setting to pending since we have a pull request. Thanks Harald! :)
Posted on 12 Jul 2013, 5:07 by ushma shah
@test, I have checked the patch for this and it is working fine after applying path.
Posted on 11 Jun 2014, 18:52 by Roberto Segura

@test success

Fixed in:
https://github.com/joomla/joomla-cms/commit/8cd80515a8504d39b081f880b1e35dc6c27a6067

I could not find who to credit because the source branch was removed from github. I did my best