Summary


This module shows a Google Map with basic options in a given module position. User can define the location either by Longitude/Latitude or by address. Additionally user can set the zoom level, map size as well.
Pr : https://github.com/joomla-projects/joomla-cms/pull/79
PR against master: https://github.com/joomla/joomla-cms/pull/1917
Branch : https://github.com/lasinducharith/joomla-cms/tree/maps_module
Opened On:
26 Jul 2013, 6:06 by Lasindu Charith
Closed On:
23 Aug 2014, 8:01
Status:
Closed

Responses

Posted on 11 Sep 2013, 9:12 by Elin Waring

Lasindu can you please make this a PR agains master? 

I've been running with thie module for a while and it works well. Also I will say that i really want to  provide an option to embed this module inside a content layout (using a module provies a way to configure and style it if desired and just use JModuleHelper to display it) so I really would like to see it in the core. 
Posted on 11 Sep 2013, 21:22 by Elin Waring

Updated pull requst link.
Posted on 1 Oct 2013, 2:44 by Janich Rasmussen

@test

A few error messages found in modules/mod_maps/tmpl/default.php that should be converted to language strings, but found no other issues in module.
Posted on 1 Oct 2013, 3:25 by Lasindu Charith

Thanks Janich, Fixed.
Posted on 1 Oct 2013, 10:55 by Tobias Zulauf

@test

looks good for me. But one smal issue ;)

I think we should use the version 3.2/3.2.0 instend of 3.1/3.1.0 in the xml files and the php headers (@since) :)
Posted on 9 Oct 2013, 11:48 by Thomas Jackson

Is the change of the version numbers the only thing required to get this feature implemented in the trunk? Or is further testing required?
Posted on 9 Oct 2013, 13:03 by Tobias Zulauf

@thomas:

you can test this as so much testes as we can have bevor implemented are good :)
Posted on 11 Oct 2013, 9:39 by Thomas Jackson

@Lasindu or @Tobias:

I am running the current master of Joomla 3.x. I installed this patch via the Joomla Patch Tester. It installed successfully, but for some reason the module does not show up on the list of modules in Module Manager. I know I am doing something wrong. Any advice? Many thanks.
Posted on 23 Aug 2014, 8:01 by Brian Teeman

Thank you for your contribution. We have now moved our tracking process to http://issues.joomla.org/ so please do not update the issue here. The link on the new tracker for this issue is  http://issues.joomla.org/tracker/joomla-cms/1917