Summary


I encountered a problem which is so much strange that I don't know if is due to Joomla or something in my system. Can someone confirm this issue?

It affects the new version of chosen dropdown (0.14) introduced in Joomla 3.2.3.

Following the instructions to reproduce the problem on Joomla backend, but it affects all the dropdown fields, regardless they are displayed on backend or frontend.

It only affects the chosen select boxes containing more than 10 items, on which the search input appears.

Login to the Joomla backend selecting an RTL language, for example Arabic Unitag.

Go to Extensions > Module Manager. Yes, me neither understand a word there. You have to refer to the elements position.

Select the module "Main menu".

Once entered in module editing, search for the field "End Level". This is a good field to fire the bug, because it have more than 10 items.

Select one item on the list.

The most of the page elements disappear (see my screenshots)
Opened On:
10 Mar 2014, 8:12 by Demis Palma
Status:
Confirmed

Filed Under

  • Apache 2.2.x
  • Javascript
  • No Platform Implications

Responses

Posted on 10 Mar 2014, 8:48 by Brian Teeman

Setting the correct priority according to our http://docs.joomla.org/Bug_Tracking_Process#Issue_Priorities
Posted on 10 Mar 2014, 10:56 by Demis Palma

Well, level "critical" is too much, sorry.

However, if confirmed the application is not workable. At least not for rtl languages. In this case the level should not be "normal".
Posted on 11 Mar 2014, 13:16 by Demis Palma

I found a way to reproduce the problem on frontend side too.

Select the template Beez3. This way all the select boxes are affected.

Select a RTL language on the site side, for example Arabic Unitag.

Browse a site page containing a select box, for example http://website/index.php?option=com_search

Select a value from the select box control present in this page.

The most of the page disappears.

 
Posted on 27 Jul 2014, 4:14 by Roland Dalmulder

An easier way to reproduce this using English is to edit the file language\en-GB\en-GB.xml and set the <rtl>0</rtl> on line 15 to <rtl>1</rtl>.
Posted on 27 Jul 2014, 5:22 by David Hurley

I cannot replicate this issue with 3.3.4
Posted on 4 Aug 2014, 15:48 by Roberto Segura

I could not replicated this neither vs the latest staging.

I tested it on backend & frontend ( see screenshots) with RTL enabled. And with debug enabled/disabled just in case it was an issue in minified versions.

Can this be a browser cache history?

 
Posted on 5 Aug 2014, 0:21 by Roland Dalmulder

@davidhurley and @phproberto this issue is only present with the Beez template and not with the Protostar template. Make sure you use that template to test. The screenshots posted by Roberto show the Protostar template.

With the latest staging I can only reproduce the issue in the frontend not the backend.
Posted on 5 Aug 2014, 6:12 by Roberto Segura

Thanks Roland.

Setting it as confirmed as I was able to reproduce the issue on latest staging with Beez on search results view. Clicking on any select box makes the content dissappear.
Posted on 28 Sep 2014, 3:24 by Demis Palma

Please note that it affects the backend as well, as described in my first report and RTL users a re unable to access some basic Joomla features.

So, now that finally it is confirmed can somebody please set a higher priority?