• Project: Joomla!
  • SubProject: CMS
  • Severity: High
  • Versions: 1.5.0 through 3.4.6
  • Exploit type: Remote Code Execution
  • Reported Date: 2015-December-15
  • Fixed Date: 2015-December-21
  • CVE Number: requested


The Joomla Security Strike team has been following up on the critical security vulnerability patched last week. Since the recent update it has become clear that the root cause is a bug in PHP itself. This was fixed by PHP in September of 2015 with the releases of PHP 5.4.45, 5.5.29, 5.6.13 (Note that this is fixed in all versions of PHP 7 and has been back-ported in some specific Linux LTS versions of PHP 5.3). This fixes the bug across all supported PHP versions.

Affected Installs

Joomla! CMS versions 1.5.0 through 3.4.6


Upgrade to version 3.4.7


The JSST at the Joomla! Security Centre.

Reported By: Found by JSST and independently reported by Dennis Hermatski